• Advertisement
Sign in to follow this  

[Resolved]Initial depthpass problems on Radeon cards

This topic is 4347 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hey everyone, In my engine, before the lighting pass, I do a Z-fill pass, to speed up rendering. On geforce cards, it works nicely. On a FX 5200, with full shaders, the speed increase is 34 fps to 64 fps, almost twice as fast. But, on radeon cards, I get z fighting artifacts. If I set depthbias to anything other than 0, such as 0.01, 1, 16, 128 (values I tried), my depth pass looks like it was rendered with ZEnable set to false, and the zbuffer contains the actual rendered z values. Example, I have a pillar infront of a wall. On the geforce, after the depthpass, the pillar is rendered and the wall it occludes is rejected (early z). On the radeon, with the messed up z values, the wall shows up infront of the pillar in the depthpass, so the whole wall and the whole pillar are drawn. Does anyone know what I'm doing wrong? My problem isn't occlusions, it's just that on radeon cards, with zbias to anything other than 0, it seems to disable the zbuffer, even if I put ZEnable = True after setting the depthbias. Thanks, Cade [Edited by - CadeF on March 30, 2006 6:14:52 PM]

Share this post


Link to post
Share on other sites
Advertisement
What does the reference rasterizer display when rendering the same scene?

Share this post


Link to post
Share on other sites
The reference rasteriser, as expected, displays what the geforce displays, no zfighting issues at all.

Share this post


Link to post
Share on other sites
These graphics cards have all shown the same problem, the X1900XTX has the latest drivers, the 9800XT a version behind the latest and the 9600XT 2 versions behind the latest. The Radeon Mobility has the drivers from the OEM CD, which is dated 2-27-2006.

Radeon 9600XT 128MB
Radeon 9800XT 256MB
Radeon Mobility X1800
Radeon X1900XTX 512MB

Offtopic: Also, would anyone know which drivers could I use to update the Radeon Mobility? Only the drivers on the OEM CD seem to work, I cant find any drivers which will install.

Share this post


Link to post
Share on other sites
Hi,

try smaller ZBias values, maybe that helps (I use much smaller ones than you use now, however I don't have a depth-first pass).

Quote:
Original post by CadeF
Offtopic: Also, would anyone know which drivers could I use to update the Radeon Mobility? Only the drivers on the OEM CD seem to work, I cant find any drivers which will install.
For notebooks, you should always find your latest drivers from the website of the notebook manufacturer (officially). Also, there are patched versions of the non-mobility drivers that will install on laptops, you can find some here:

DriverHeaven
LaptopVideo2Go

(I don't know if using these patched drivers has any drawbacks or side effects compared to the official ones, so take care)

kp

[Edited by - kovacsp on March 30, 2006 5:24:00 AM]

Share this post


Link to post
Share on other sites
I tried a z-bias of 0.00001 and it still acts like my zbuffer is nonexistant.

Offtopic: Thanks, but in every list of supported cards with drivers, the latest mobility card is x800, I'm looking for x1900.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement