Archived

This topic is now archived and is closed to further replies.

Geocyte

GL's framerate switch - can I turn it off?

Recommended Posts

Geocyte    196
I''ve recently been looking at porting old glide code to OpenGL and hit a problem I''m hoping someone can help with. One of the programs provides visuals for music but when I try to draw too much, instead of just slowing down GL does it''s mad framerate switch and the visuals appear to double in speed. It looks shit. Slowdown is acceptable - synchronisation can be picked up again later, is there a way I can turn this feature off? Any other suggestions about how to keep sound/visual sync spot on would be gratefully recieved. Peace. Geocyte Has Committed Suicide.

Share this post


Link to post
Share on other sites
Guest Anonymous Poster   
Guest Anonymous Poster
The glFlush function forces execution of OpenGL functions in finite time. But I think you should look at the program itself instead.

Share this post


Link to post
Share on other sites
zedzeek    528
perhaps u need to sync to the monitors vertical refresh
on windows (4 nvidia card theres a checkbox in the disp[lay properties )
also theres an extension winswapinterval (example on my site)

rerad your post i think perhaps u need to have the program run the same speed on all machines (this has been answered heaps here and in other places)

http://members.xoom.com/myBollux

Share this post


Link to post
Share on other sites