Jump to content
  • Advertisement
Sign in to follow this  
silverphyre673

boost::filesystem isn't linking correctly

This topic is 4525 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I've used boost before in several projects, and I really like the library. I'm trying to use boost::filesystem to get all the files in a directory and attempt to open them as image files, but, unfortunately, my application won't link now that I've used function calls from namespace boost::filesystem. It says that all the function calls are undefined. Now, if I use something like boost::lexical_cast, that links fine. It seems to just be the boost::filesystem stuff. I plunked the whole boost directory of include files right into my include directory with everything else, and I'm using it just like I've always used it. Any ideas? Help is appreciated!

Share this post


Link to post
Share on other sites
Advertisement
Just including the file only works for most of the Boost libraries since they are primarily just template definitions which all exist in the headers you include. For libraries like filesystem you actually have to build Boost and link to the appropriate libraries which are created.

Share this post


Link to post
Share on other sites
Not so, you can just add the boost specific code (not just the headers) into your project and iirc, that works fine.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!