Sign in to follow this  
Axesor

Text is not showing at all

Recommended Posts

0)Do you get any error messages?
1)Do you have the "Courier New" font on your system? Maybe some program or what ever has damage the file??
2)Do you have any problems with other opengl applications specially other nehes samples?

Share this post


Link to post
Share on other sites
I copied the hole text from lesson 13 ( in my programm, but I couldn´t see the text. After some tests I get that the text is very dark and on the black screen I couldn´t see it. After killing the line:

if (!LoadGLTextures()) //Jump To Texture Loading Routine
{
return FALSE; // If Texture Didn't Load Return FALSE
}

the problem with the text was fixed, but now the texture dont work.
maybe this ist the solution for your problem.
but I need help!: why the hell happens this?!

Share this post


Link to post
Share on other sites
- are the texture dimentions powers of 2?
- do you have GL_TEXTURE_2D enabled?
- did you bind the texture?
- did you set texture coordinates?
- does glGetError() return somthing other than GL_NO_ERROR?

Share this post


Link to post
Share on other sites
Maybe I haven´t told my problem so well...

The textures work!
The text works!

But if I enable textures the Text have the wrong color. I tried to implement different types of color-commands (GLcolor3f for example), but the text is not effectedt by that.

I dont get any error-messages, but my text is difficult to read...

If you give me your email I can mail you my programtext and data.

Share this post


Link to post
Share on other sites
Did you set glColor4f(1,1,1,1); just before rendering?
Put it at the top of the glPrint function.

allso disable lighting when drawing text, lighting is usuarly one of the major sources of rendering problems in opengl.

Share this post


Link to post
Share on other sites
another thing that might cause that problem is your not disabling GL_TEXTURE_2D after your done with it. try something like this:

glEnable(GL_TEXTURE_2D);
//call texture functions and bind textures
glDisable(GL_TEXTURE_2D);
//now call other functions
glColor3f(1,0,0);
glPrint("text");

I had the same problem, and it was just a matter of turning off GL_TEXTURE_2D, so try that.

--nathan

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this