Sign in to follow this  
Rain 7

OPENAL music troubles

Recommended Posts

Hi. I am trying to get a game's music to work and it requires the application OPENAL. I downloaded openAL but the music for the game is still not working. What might be the problem? Do I need to do anything special with OPENAL to activate it after download? Thanks Ryan

Share this post


Link to post
Share on other sites
Nope, April 2nd. Ok then. So you do realize OpenAL is not an application at all, it's a library of functions. You don't just download/install it and instantly get music in your program. You have to program it to load the music, play it etc.

Go here for some tutorials:
http://www.devmaster.net/articles.php

All the way to the bottom, last section: Sound and Music Programming

Edit: Fixed a few typos.

Share this post


Link to post
Share on other sites
Hmmm...yea you think my comment is pretty dumb. I know. :p

Let me rephrase here...I believe the OPENAL sound drivers for the game are actually installed in the appropriate folder but for some reason they aren't playing. What do you think the problem might be?

....thanks

Ryan

Share this post


Link to post
Share on other sites
OpenAL actually uses DirectSound, etc on Windows and other libraries on Linux, etc to actually produce the audio. It's most likely that you're not initializing OpenAL correctly if you're having issues. Can you get your application to play a simple wave file with OpenAL?

OpenAL is a programmers tool, it's not to make music. It's to allow games to use the computers audio card to pump it out to the speakers.

Provide some code.

Share this post


Link to post
Share on other sites
Hmmm...well now that you mention it, there may be no problem with the OPENAL files themselves, it may be the audio source player which isn't recognizing OPENAL. How do I find the code commands for you ?

I am not a programmer so any help you can give me is greatly appreciated.

Thx

Ryan

Share this post


Link to post
Share on other sites
Yeah, if your audio program isn't working there is nothing you can do about it (unless you wrote it and have the source code, which it doesn't sound like you do). If the audio program that is having issues uses OpenAL there is nothing you can do, contact them, try trouble shooting it etc.

Maybe if you tell us what OS you have, what program your trying to use and what the issue is, someone might be able to help you (or we can point you to the correct part of the forum, or if needed to other forums for that help).

Mike

Share this post


Link to post
Share on other sites
He's got a Mac. And OpenAL should be able to play .OGG files but based on what I've read on DevMaster.net the newer version of OpenAL has an extra step involved in the setup process that the original version didn't have. A link to the forum posts is here.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this