Jump to content
  • Advertisement
Sign in to follow this  
discman1028

Direct3D Debug Mode - How to release project?

This topic is 4462 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

When I build my D3D app and send to a friend, he gets the error: "d3dx9d_28.dll does not exist". He does have the DX9 runtime installed. Now, I turned off Debug runtime from the control panel. But do I need to turn off something else within Visual Studio (C++ .NET 2003) to produce an executable that doesn't require this debug dll? Thanks

Share this post


Link to post
Share on other sites
Advertisement
You will need to compile in Release, but I think you will still need the release version of the DLL. I'm not that familiar with the history of this DLL, but if I remember correctly about a year ago microsoft took it out of the DX runtime, and you are supposed to add the redistrubuter to you game's installer (or something). You are not supposed to, but for the sake of send something to you buddy, I would just copy the DLL into the same folder as your exe, and send it to him like that.

But you're not supposed to redistubute that DLL...

Matt

Share this post


Link to post
Share on other sites
You need to change the current build configuration of your project from Debug to Release mode. This will make the compiler build the executable with the release DX libraries. In 2005 the option is under Build > Configuration Manager. Since its almost the same in MSVC6, I'd assume its almost the same in 2003 as well.

Just switch to release mode, rebuild, and see if that changes anything. The other option is to directly modify the build options - if you change _DEBUG to NDEBUG in the preprocessor definitions it should work too. But use the configuration manager - it makes life easier by making all those changes for you.

Also do note there are a couple of a lot of other differences between Debug and Release mode - most of them having to do with optimizations (at the cost of safety).

Share this post


Link to post
Share on other sites
Actually, I had it in Release mode. Looking at my compiler options, it also had NDEBUG set...

/O2 /D "WIN32" /D "NDEBUG" /D "_WINDOWS" /D "_MBCS" /FD /EHsc /ML /GS /Fo"Release/" /Fd"Release/vc70.pdb" /W3 /nologo /c /Wp64 /Zi /TP

hmmmmm... still no go.

Anyhow, I found d3dx9d_28.dll in the SDK folder, I'll try "telling my friend to download the SDK" for now.

Share this post


Link to post
Share on other sites
Then it is clearly obvious that you are linking a debug library in your Release profile. You need to adjust your Release profile so that it links to d3dx9_28.dll .

Share this post


Link to post
Share on other sites
Quote:
Original post by Mastaba
Then it is clearly obvious that you are linking a debug library in your Release profile. You need to adjust your Release profile so that it links to d3dx9_28.dll .

This entails linking to d3dx9.lib instead of d3dx9d.lib. Just change that, and you should be good.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!