Sign in to follow this  

Frustrating matrix problems

This topic is 4256 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I'm trying to do something pretty standard: rotate a 3D object around a point, using an axis defined by a unit vector, and an angle defined by a float. It works fine 90% of the time, but in certain positions, the matrix gets transformed to a bunch of huge negative values, like an overflow occured. Has anyone experienced a similar problem? - Evan

Share this post


Link to post
Share on other sites
Okay I found the error. I had accidentally put a transformation from local space to world space inside a loop that should have been outside the loop. (Something to look for if your matrices ever blow up :D )

Also, I'm still trying to figure out how to paste source code with syntax coloring. Any help?

- Evan

Share this post


Link to post
Share on other sites

This topic is 4256 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this