Sign in to follow this  
tolliner

Incorrect Alpha Blending with Particles

Recommended Posts

tolliner    126
I’m having difficulty locating the problem I’m having with my program. For some reason when I run the program the color value which I am applying to each particle is not taking effect, rather all the particle’s color is being set to a blue color. This is the first time I’ve worked with alpha blending so it very well could be a stupid error. Below I have the code for my particle system. The files I’m using as the texture is a .bmp gray scale 64x64 picture. Any help would be greatly appreciated! Here is a picture of how it should look (using a particle engine i found online) http://img.photobucket.com/albums/v256/toffty/good.jpg Here is how mine currently looks: http://img.photobucket.com/albums/v256/toffty/bad.jpg Here is the code (this is writen in DirectX) http://www.geocities.com/tolliner2/ParticalSystem.zip PS: And yes I have compaired my source with the one I found online... but after 5 hours I still have not found the answer PPS: If more of my code is needed let me know, I only posted what I think is the problem

Share this post


Link to post
Share on other sites
tolliner    126
I am stupid. I found my problem, I had Pointsize in my FVF flag but not in the definition

[Edited by - tolliner on April 24, 2006 10:55:57 AM]

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this