Sign in to follow this  
Mark Duffill

VideOh avc 2010 Mpeg2/DirectShow and filters magic

Recommended Posts

Mark Duffill    156
Hi All, Background: At work we have a audio+video capture/preview utility written in house. Previewing and capturing at full resolution is a CPU killer if done in software, so I suggested a hardware encoding card as it does all the grunt work on card freeing up the CPU. We got the Adaptec VideOh! PCI (AVC-2010) card, this does the job a treat, but only works with the supplied software. The supplied software works fine but lacks some features the users want that is in our utility, basically on the fly screen shots and bigger preview window for the video. Problem: Anyhow the in house utility is based on direct show and works fine with other capture devices, but not the AVC-2010. It just gets a media_video error when trying to initalise a filter/graph and that. So has anyone experienced this problem before and know of the solution? I feel it has something to do with the card spurting out MPEG2 data instead of the normal streams and thus might need the direct show filter graph changing to work with it. However as always is the case its seems hard to find any source [code] that shows how to configue such things. Any help or examples would be appreciated! Mark.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this