Sign in to follow this  

Culling faces

This topic is 4250 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Does this just work with a dot product of a camera vector with a faces normal? Im assuming it works like: glNormal3f(_,_,_); glVertex3f(_,_,_); glVertex3f(_,_,_); glVertex3f(_,_,_); So when it calls a draw function like glVertex, it checks the last normal that was loaded in. Correct?

Share this post


Link to post
Share on other sites
...or clockwise/counterclocksie if there arn't any normals.

About the glNormal3f.. I havn't used imidiate mode for ages, but when you use normals from VBO:s, it uses those normals for the culling.

Share this post


Link to post
Share on other sites
So when I cull the front AND back faces, shouldnt my framerate increase? I thought thats the point of culling but maybe I messed up something. Its not drawing anything on the screen, obviously , but the framerate is still the same.

Share this post


Link to post
Share on other sites
Quote:
but when you use normals from VBO:s, it uses those normals for the culling.

no theres no difference with VBO

glNormal3f(_,_,_); have no influence on wether a polygon is culled or not.

Quote:
but the framerate is still the same.

it should make a bit of a difference (make sure your window is small (clear is an expensive operation) also disable vsync

Share this post


Link to post
Share on other sites
Quote:
Original post by dpadam450
So when I cull the front AND back faces, shouldnt my framerate increase? I thought thats the point of culling but maybe I messed up something. Its not drawing anything on the screen, obviously , but the framerate is still the same.


Culling both back and front shouldn't leave you with anything. ;)

Check to see if you have vsync turned on. This will lock your framerate and might be the cause.

Share this post


Link to post
Share on other sites

This topic is 4250 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this