Sign in to follow this  
Ademan555

hw_random: RNG not detected

Recommended Posts

Geeze, this thing is giving me a headache... I finally installed ubuntu on my laptop. Boy was that a mistake. When i try and start it up i get the message "hw_random: RNG not detected" somewhere in the boot proccess (either late in LILO's lifetime or early in ubuntu's) and i haven't the slightest clue how to fix this. I've been told to simply remove the module, but I don't know for sure how to do that, and i sure as heck don't know how to do that lacking even a bash console. So what do I do? thanks a ton -Dan

Share this post


Link to post
Share on other sites
Which version of Ubuntu are you using? I don't recall hw_random being loaded in the versions I've used and I don't quite see why it wouldn't boot because of the failure to load it.

Anyway. There should be some other boot option (e.g., "recovery mode" or single user mode) at the LILO menu. Try to boot to that. Or, if you're comfortable enough to know how to do it, use a Live-CD and the mount the root or "/etc" partition (whichever has "/etc" in it) read-write. Open "/etc/modules" in a text editor and see if there's a line with "hw_random" on it. If so, remove it. If not, I'll try again :).

Share this post


Link to post
Share on other sites
Thanks a lot for that. I really appreciate it. Now you said to change things at LILO's boot menu... may I ask how i get to LILO's menu? [b]I don't know jack about LILO (and i'm a linux n00b to boot). But I understand the LiveCD approach, and I may very well do that, but for future reference could you explain the LILO technique to me? I'm not in a position to try either till later today. But thanks a ton for it all!

cheers
-Dan

Share this post


Link to post
Share on other sites
Hrm, when I tried the LiveCD which definitely worked on my other computer (desktop) and i THOUGHT had worked on my laptop as well, it failed at "starting hotplug subsystem". I'm going to see if the liveCD works on this computer (desktop) but I would appreciate alternative method's in the meantime

thanks
-Dan

Share this post


Link to post
Share on other sites
Quote:
Original post by Ademan555
Now you said to change things at LILO's boot menu... may I ask how i get to LILO's menu?

I haven't used LILO in a bit, so I'm a little rusty. If you want to skip the menu thing or it's not being shown: try typing "linux single" and hitting enter ("linux 1" might work also, but try single first).

Share this post


Link to post
Share on other sites
When/where do i type "linux single" ? I don't have control over input at any point before the problems (in both cases) other than f2 to enter bios setup

cheers
-Dan

Share this post


Link to post
Share on other sites
i thought ubuntu only uses grub, not lilo. i think the grub menu also had a "recovery mode" boot option that boots the system into single user mode (init 1) to let you fix any problems.

Share this post


Link to post
Share on other sites
Thanks both of you. And for the record, ubuntu wanted to install lilo by default... it reccomended grub though... but i chose not to since i wanted my main partition to be xfs and apparently grub doesnt like xfs

thanks
-Dan

Share this post


Link to post
Share on other sites
Sign in to follow this