• Advertisement
Sign in to follow this  

OpenGL Textures displaying incorrectly?

This topic is 4293 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi guys, i have been working on a custom 3d model file format recently, however when i render the models with directx using ID3DXMesh, the textures appears to be in the wrong place as show below. DirectX i am pretty sure that i have exported the correct vertex information becos when i tried rendering the models with my previous opengl based engine, everything seems fine. Opengl the below code shows how i load the vertex information to ID3DXMesh

void CMGS::ConvertToD3DMesh()
{
	int i,j;

	D3DVERTEXELEMENT9 decl[] = 
	{
		{0, 0, D3DDECLTYPE_FLOAT3, D3DDECLMETHOD_DEFAULT, D3DDECLUSAGE_POSITION, 0},
		{0, 12, D3DDECLTYPE_FLOAT3, D3DDECLMETHOD_DEFAULT, D3DDECLUSAGE_NORMAL, 0},
		{0, 24, D3DDECLTYPE_FLOAT2, D3DDECLMETHOD_DEFAULT, D3DDECLUSAGE_TEXCOORD, 0},
		{0, 32, D3DDECLTYPE_FLOAT3, D3DDECLMETHOD_DEFAULT, D3DDECLUSAGE_TANGENT, 2},
		{0, 44, D3DDECLTYPE_FLOAT3, D3DDECLMETHOD_DEFAULT, D3DDECLUSAGE_BINORMAL, 3},
		D3DDECL_END()
	};

	//create the vertex declaration
	g_d3dDevice->CreateVertexDeclaration(decl, &m_decl);

	if(FAILED(D3DXCreateMesh(m_totalFaceCount,m_totalVertexCount,D3DXMESH_MANAGED | D3DXMESH_32BIT,decl,g_d3dDevice,&m_pMesh)))
		ErrorMsg("Failed to ceate d3d mesh");

	XYZ_ST_TBN_VERTEX *tempVertices = NULL;	
	m_pMesh->LockVertexBuffer(0, (void**)&tempVertices);

	for(i = 0; i < pMeshes.size(); ++i)
	{
		for(j = 0; j < pMeshes.numVertices; ++j)
		{
			tempVertices->vertex = pMeshes.pVertices[j].vertex; 
			tempVertices->normal = pMeshes.pVertices[j].normal; 
			tempVertices->texcoord = pMeshes.pVertices[j].texCoord;
			tempVertices++;
		}
	}

	m_pMesh->UnlockVertexBuffer();

	DWORD *tempIndices = NULL;
	m_pMesh->LockIndexBuffer(0, (void**)&tempIndices);

	for(i = 0; i < m_totalFaceCount*3; ++i)
	{
		*tempIndices = i;
		tempIndices++;
	}

	m_pMesh->UnlockIndexBuffer();

	DWORD *tempAttrib = NULL;
	m_pMesh->LockAttributeBuffer(0, &tempAttrib);

	//sort mesh by material
	for(i = 0; i < pMeshes.size(); ++i)
	{
		for(j = 0; j < pMeshes.numFaces; ++j)
		{
			*tempAttrib = pMeshes.matID;
			tempAttrib++;
		}
	}

	m_pMesh->UnlockAttributeBuffer();

	DWORD *pAdjacency = new DWORD[m_pMesh->GetNumFaces()*3];
	m_pMesh->GenerateAdjacency(1e-6f, pAdjacency);

	if(FAILED(D3DXComputeNormals(m_pMesh,pAdjacency)))
		ErrorMsg("Compute normals for MGS failed");
		
	if(FAILED(D3DXComputeTangent(m_pMesh,0,2,3,1,pAdjacency)))
		ErrorMsg("Compute tangents for MGS failed");

	//D3DXMESHOPT_ATTRSORT
	if(FAILED(m_pMesh->OptimizeInplace(D3DXMESHOPT_VERTEXCACHE, pAdjacency, NULL, NULL, NULL)))
		ErrorMsg("OptimizeInplace for MGS failed");

	SAFE_DELETE(pAdjacency);
}


I have been stuck with this problem for a week now....[help]any help would be deeply appreciated.

Share this post


Link to post
Share on other sites
Advertisement
Hi , what is your 3d-model file's format???? .X????
If so , which tool you use to make model??????
By the way , are you a fun of MGS(metal gear solid)?????????

Share this post


Link to post
Share on other sites
Have you debugged/outputted which texture is getting associated with which subset?

Strikes me that the obvious answer is that they're getting muddled up - either by a mistake on your part (not looking up/using the right texture) or due to some difference in the way that the data is being stored.

With a bit of debug output you should be able to see if theres a pattern to where the data is getting misinterpretted. This'll be easier if you have some reference data (e.g. the ordering/pairing for your OpenGL renderer) to compare against.

I can't think of any reason why D3D would intentionally swap the textures around [smile]

Cheers,
Jack

Share this post


Link to post
Share on other sites
If the model in the screenshot has been unwrapped to create a uvmap (one mesh with one texture mapped over it properly [wink]) ..then it might be a case of the uv-coords needing inverted/flipped. You could try flipping the u-coords and/or the v-coords and seeing if that makes a difference.

If it is a tiled texture over different mesh subsets then it is mostly likely a case of things getting muddled up as Jack said [smile]

Regards,
ViLiO

Share this post


Link to post
Share on other sites
thx for the sugguestions, i managed to solved the problem by simply inverting the v-coordinates juz as ViLiO mentioned.

Thx again for the help guys[smile]

Regards,
MCafe

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
  • Advertisement
  • Popular Tags

  • Advertisement
  • Popular Now

  • Similar Content

    • By LifeArtist
      Good Evening,
      I want to make a 2D game which involves displaying some debug information. Especially for collision, enemy sights and so on ...
      First of I was thinking about all those shapes which I need will need for debugging purposes: circles, rectangles, lines, polygons.
      I am really stucked right now because of the fundamental question:
      Where do I store my vertices positions for each line (object)? Currently I am not using a model matrix because I am using orthographic projection and set the final position within the VBO. That means that if I add a new line I would have to expand the "points" array and re-upload (recall glBufferData) it every time. The other method would be to use a model matrix and a fixed vbo for a line but it would be also messy to exactly create a line from (0,0) to (100,20) calculating the rotation and scale to make it fit.
      If I proceed with option 1 "updating the array each frame" I was thinking of having 4 draw calls every frame for the lines vao, polygons vao and so on. 
      In addition to that I am planning to use some sort of ECS based architecture. So the other question would be:
      Should I treat those debug objects as entities/components?
      For me it would make sense to treat them as entities but that's creates a new issue with the previous array approach because it would have for example a transform and render component. A special render component for debug objects (no texture etc) ... For me the transform component is also just a matrix but how would I then define a line?
      Treating them as components would'nt be a good idea in my eyes because then I would always need an entity. Well entity is just an id !? So maybe its a component?
      Regards,
      LifeArtist
    • By QQemka
      Hello. I am coding a small thingy in my spare time. All i want to achieve is to load a heightmap (as the lowest possible walking terrain), some static meshes (elements of the environment) and a dynamic character (meaning i can move, collide with heightmap/static meshes and hold a varying item in a hand ). Got a bunch of questions, or rather problems i can't find solution to myself. Nearly all are deal with graphics/gpu, not the coding part. My c++ is on high enough level.
      Let's go:
      Heightmap - i obviously want it to be textured, size is hardcoded to 256x256 squares. I can't have one huge texture stretched over entire terrain cause every pixel would be enormous. Thats why i decided to use 2 specified textures. First will be a tileset consisting of 16 square tiles (u v range from 0 to 0.25 for first tile and so on) and second a 256x256 buffer with 0-15 value representing index of the tile from tileset for every heigtmap square. Problem is, how do i blend the edges nicely and make some computationally cheap changes so its not obvious there are only 16 tiles? Is it possible to generate such terrain with some existing program?
      Collisions - i want to use bounding sphere and aabb. But should i store them for a model or entity instance? Meaning i have 20 same trees spawned using the same tree model, but every entity got its own transformation (position, scale etc). Storing collision component per instance grats faster access + is precalculated and transformed (takes additional memory, but who cares?), so i stick with this, right? What should i do if object is dynamically rotated? The aabb is no longer aligned and calculating per vertex min/max everytime object rotates/scales is pretty expensive, right?
      Drawing aabb - problem similar to above (storing aabb data per instance or model). This time in my opinion per model is enough since every instance also does not have own vertex buffer but uses the shared one (so 20 trees share reference to one tree model). So rendering aabb is about taking the model's aabb, transforming with instance matrix and voila. What about aabb vertex buffer (this is more of a cosmetic question, just curious, bumped onto it in time of writing this). Is it better to make it as 8 points and index buffer (12 lines), or only 2 vertices with min/max x/y/z and having the shaders dynamically generate 6 other vertices and draw the box? Or maybe there should be just ONE 1x1x1 cube box template moved/scaled per entity?
      What if one model got a diffuse texture and a normal map, and other has only diffuse? Should i pass some bool flag to shader with that info, or just assume that my game supports only diffuse maps without fancy stuff?
      There were several more but i forgot/solved them at time of writing
      Thanks in advance
    • By RenanRR
      Hi All,
      I'm reading the tutorials from learnOpengl site (nice site) and I'm having a question on the camera (https://learnopengl.com/Getting-started/Camera).
      I always saw the camera being manipulated with the lookat, but in tutorial I saw the camera being changed through the MVP arrays, which do not seem to be camera, but rather the scene that changes:
      Vertex Shader:
      #version 330 core layout (location = 0) in vec3 aPos; layout (location = 1) in vec2 aTexCoord; out vec2 TexCoord; uniform mat4 model; uniform mat4 view; uniform mat4 projection; void main() { gl_Position = projection * view * model * vec4(aPos, 1.0f); TexCoord = vec2(aTexCoord.x, aTexCoord.y); } then, the matrix manipulated:
      ..... glm::mat4 projection = glm::perspective(glm::radians(fov), (float)SCR_WIDTH / (float)SCR_HEIGHT, 0.1f, 100.0f); ourShader.setMat4("projection", projection); .... glm::mat4 view = glm::lookAt(cameraPos, cameraPos + cameraFront, cameraUp); ourShader.setMat4("view", view); .... model = glm::rotate(model, glm::radians(angle), glm::vec3(1.0f, 0.3f, 0.5f)); ourShader.setMat4("model", model);  
      So, some doubts:
      - Why use it like that?
      - Is it okay to manipulate the camera that way?
      -in this way, are not the vertex's positions that changes instead of the camera?
      - I need to pass MVP to all shaders of object in my scenes ?
       
      What it seems, is that the camera stands still and the scenery that changes...
      it's right?
       
       
      Thank you
       
    • By dpadam450
      Sampling a floating point texture where the alpha channel holds 4-bytes of packed data into the float. I don't know how to cast the raw memory to treat it as an integer so I can perform bit-shifting operations.

      int rgbValue = int(textureSample.w);//4 bytes of data packed as color
      // algorithm might not be correct and endianness might need switching.
      vec3 extractedData = vec3(  rgbValue & 0xFF000000,  (rgbValue << 8) & 0xFF000000, (rgbValue << 16) & 0xFF000000);
      extractedData /= 255.0f;
    • By Devashish Khandelwal
      While writing a simple renderer using OpenGL, I faced an issue with the glGetUniformLocation function. For some reason, the location is coming to be -1.
      Anyone has any idea .. what should I do?
  • Advertisement