Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

MindWipe

Download and try my DirectX Demo!

This topic is 6459 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I made this DirectX demo that I want you to try so that I get some stats how fast it runs. It''s actualy more like a "Engine-test" for my Visual & Audio Engine(or wrapper). But it has got a few more features like Alphablend. What do you think? And how fast did it run? Or did it run at all? Remember to read the ReadMe.txt. It requires DirectX7. Download it from here: http://virwar.50megs.com/index.html (Damn 50megs.com for not letting you download directly) /MindWipe "If it doesn''t fit, force it; if it breaks, it needed replacement anyway."

Share this post


Link to post
Share on other sites
Advertisement
Your engine doesn''t work on my machine!

--- Visual Logging File Created ---

Logging:
VisualEngine Init started...
MMX Support detected
DirectDraw Object created
Cooperative Level succesfully set
Display Mode succesfully set
FrontBuffer created
BackBuffer created
Direct Draw is ready & working!

No AudioLog.txt was created!

AMD 650 Mhz
Windows 2000
128 MB RAM

get it run!! I want to try it!

Share this post


Link to post
Share on other sites
Hmm... the only thing I can see could be the problem is that when you unzipped it, did it create two folders: Images & Sounds
If not, put all the Images in "Images" ad all the sound + music into "Sounds".

This is my AudioLog.txt
quote:

--- Sound Logging File Created ---

Logging:
AudioEngine Init started...
Direct Sound Object created
Cooperative Level succesfully set
DirectSound is ready & working!
Init Direct Music started...
Performance Object created
Initialized Performance Object
Added Port
Loader created succesfully
Direct Music is ready & working!
Loading MUSIC file: Sounds/Music.mid...
File Loaded succesfully!
Loading WAVE file: Sounds/o1.wav in 32 Buffers...
File Loaded succesfully!
Loading WAVE file: Sounds/o2.wav in 32 Buffers...
File Loaded succesfully!
Loading WAVE file: Sounds/o3.wav in 32 Buffers...
File Loaded succesfully!
Loading WAVE file: Sounds/o4.wav in 32 Buffers...
File Loaded succesfully!
Loading WAVE file: Sounds/o5.wav in 32 Buffers...
File Loaded succesfully!
Sound: Sounds/o1.wav Released
Sound: Sounds/o2.wav Released
Sound: Sounds/o3.wav Released
Sound: Sounds/o4.wav Released
Sound: Sounds/o5.wav Released
Music: Sounds/Music.mid Released
Direct Sound Released
Direct Music Loader Released
Direct Music Performancer Released

--- End Of File ---



And this is my VisualLog.txt

quote:

--- Visual Logging File Created ---

Logging:
VisualEngine Init started...
MMX Support detected
DirectDraw Object created
Cooperative Level succesfully set
Display Mode succesfully set
FrontBuffer created
BackBuffer created
Direct Draw is ready & working!
Front Buffer Released
Direct Draw Object Released

--- End Of File ---




Not really sure what else it could be. How many MB of VideoMemory do you have? And you have DirectX7 right?

/MindWipe

"If it doesn''t fit, force it; if it breaks, it needed replacement anyway."

Share this post


Link to post
Share on other sites
Really nice!
On my PIII-450, TNT2 ULTRA 32MB, 128MB RAM, WinMe, DX8:

Alpha blending on: off:
Videomem on: ~70fps ~260fps
Videomem off: ~60fps ~65fps

btw, nise Christmas tree =)


------------------
It''s me again!

Share this post


Link to post
Share on other sites
IT runs great on my machine.

My specs are:
p3-600
GeForce 256 DDR 32mb
128MB
Win98

When i use vid mem and turn alphablending off i got as high as 760fps and as low as 740. Every other mode, i got from 60 to about 80. I like how you make it zoom with just the glass part. Are you using D3D? It looks like it since every thing is smoothed out. If so, how are you making just the glass part zoom up.

-SirKnight

Share this post


Link to post
Share on other sites
yep that was the problem.
It''s flickering whole the time.
Get 69 FPS on a Voodoo 3 AGP
Keep on going that work!

Share this post


Link to post
Share on other sites
When I try downloading it with DAP I''m getting a "password required" dialog (?)
So I''ve tried downloading your demo with GetRight and that went well...

OK, here are the results:


AlphaBlend: ON
MMX enabled: ON
Video memory: OFF
46 FPS

AlphaBlend: OFF
MMX enabled: ON
Video memory: OFF
51 FPS

AlphaBlend: ON
MMX enabled: OFF
Video memory: OFF
46 FPS

AlphaBlend: ON
MMX enabled: ON
Video memory: ON
38 FPS

AlphaBlend: OFF
MMX enabled: ON
Video memory: ON
459 FPS (!)

AlphaBlend: ON
MMX enabled: OFF
Video memory: ON
51 FPS



My computer:

- PIII 5000
- 128 MB SDRAM
- GeForce2 MX 32 MB (3D Prophet)
- Win98 SE
- Unfortunality that''s all @ AGP 1x

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!