Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

CpMan

DX 8 artifacts

This topic is 6460 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Sometimes when I render a triangle using DrawPrimitive, the triangle will be draw with moving white artifacts, sort of like tv snow, even when the triangle is not moving. What is wrong.

Share this post


Link to post
Share on other sites
Advertisement
yep, and the pattern isn''t just random dot, lines will move across, then change to dots, then something else wierd.

Share this post


Link to post
Share on other sites
Hmm...sounds very strange. I don''t suppose you''ve gone over the maximum vertex buffer size? That can cause wierd glitches.

Sounds more like a hardware problem though. Presumably there''s nothing overclocked or overheating in your system (video card, agp bus, cpu etc) and your RAM is ok. Might be worth checking your bios settings as well. What kinda video card is this on?

Share this post


Link to post
Share on other sites
Another note...the program, which displays just a single triangle was created under DX7, it displays the same artifacts in 7 and 8. My video card is a TNT2 Vanta. Oh, and by the way, I get no artifacts in any other games.

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!