Jump to content
  • Advertisement
Sign in to follow this  
headhunter_pl

SDL problem with UNICODE

This topic is 4429 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Probably the topic was discussed lots of times, but Google said nothing about that :). Here's my problem. After SDL initialization I have SDL_EnableUNICODE(SDL_ENABLE); In the main loop I am polling the event SDL_PollEvent(&event) and when event.type is SDL_KEYDOWN I am trying to get the event.key.keysym.unicode . The value of event.key.keysym.unicode is always 0 when I am using any international keyboard layout :/. I am doing this under Linux/KDE environment. When I use standart english keyboard layout everything is OK, when I switch to some other (say Cyrillic, cuz the chars there are definitely different) I receive zeros. Anyone has an idea whet could be the problem? Thanx for any responce, Pavel

Share this post


Link to post
Share on other sites
Advertisement
Not sure, but I have the same problem under Windows with English keyboards. I suspect that Unicode support isn't included on the Windows version.

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
http://lists.arabeyes.org/archives/developer/2004/June/msg00160.html (the post is quite old)

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!