Sign in to follow this  
reuomi

Max 7 and Their material to .fx feature

Recommended Posts

In the material editor i says you can save to .fx, but when ever i go to save the file, type in the name and push save. it never actualy puts the file in the directory ( or just doesn't plain make it) I also noticed the dx display is always greyed out.. how do i get the save to .fx fiel to work?

Share this post


Link to post
Share on other sites
This is probably caused due to the fact that you are not using the DirectX 9 display drivers within the Max viewports, that's why the DirectX Manager is grayed out. You are probably using an older version like 8, which does not support this feature.
To change your settings within Max (assuming that you have DirectX9 installed in your computer) just go Customize > Preferences > Viewports > Display Drivers > Choose Drivers > and select DirectX 9.0.

Hope this helps!

Share this post


Link to post
Share on other sites
Ok. The dx manager is working. but i'm still not sure how to make this "save to .fx" work. I click it. give ti a name, then save. and it doesn't make the file? where can i find mroe instructions on this? or can somone here tell me how to use it

Share this post


Link to post
Share on other sites
Well, this shouldn't be that complicated at all. You just enable the "Dx Display of Standard Material" and then you choose to save the .fx file.
Works perfectly with ok me. That's the way it should work, I don't know what's wrong with the version of your 3dsMax.
Do the DX shaders appear correctly in the viewports?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this