Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

Beelzebubbles

DLLs for Canopus Pure3d card ?

This topic is 6391 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

OK this is getting annoying. I''ve been going through the NeHe GL tutorials with MSVC 6.0 and they are very well done and execute fine with the pitifully slow Windows software rendering, but I can''t seem to get it work with the accelerator card, I always get "Expected VXD version 1.4, got 1.2". The card is working fine with Unreal, GLQuake etc etc. I''ve tried various versions of opengl32.dll and 3dfxGL.dll (renamed to opengl32.dll) in the same dir as the exe I''m trying to run, the nearest I got to firing up the card was when I replaced fxmemmap.vxd in windows\system with a later version and got a green screen of death. I''ve tried the Pure3d files, the Monster3d version, the reference version, mesa dlls, the dll that comes with GLQuake, what am I doing wrong here ? Thanks, Rick.

Share this post


Link to post
Share on other sites
Advertisement
Do a search on the web for "GLSetup". It is a program that will detect your video card and download the proper drivers for running OpenGL.

Share this post


Link to post
Share on other sites
Youy should use GLSetup anyway, then after you''ve installed it, look for a file called 3dfxgl.dll or something like that, then copy and rename that file to Opengl32.dll and pu that in your program''s directory, then you will be able to run the Nehe programs with your 3DFX card. It works, I did it too.

Share this post


Link to post
Share on other sites
Thanks, I was about to give up and decided to have one more go with GLsetup, along the way I downloaded a version of fxmemmap.vxd that didn''t cause the "expected vxd version 1.4, got 1.2" error, and now it''s working with the card. In case anyone''s interested, the files that worked for me were:

In windows\system:
fxmemmap.dll 6/07/98 (8048 bytes) ( found at http://www.topqualityfreeware.com/fvxd.shtml )

opengl32.dll 11/05/98 737k ( the standard win98 dll, don''t replace it !)

in the dir where your exe is:
opengl32.dll 29/4/99 939k
(renamed from 3dfxOGL.dll extracted from the archive found at: ftp://ftp1.3dfx.com/drivers/voodoo_graphics/vg-w9x-q3.exe, but any 3dfxOGL or 3dfxVGL seem to work once renamed.

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!