Sign in to follow this  

Rusty bones

This topic is 4204 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi people, I am facing the following problem while loading the boneframe(bounds) of md3 files. Free Image Hosting at allyoucanupload.com This is a screenshot which shows the bounding rectangle developed for the data. All the three bounds(1,2,3) seems accurate in terms of their shape. Notice that (1) seems to be the bound for head (2) for torso and (3) for legs. Why arent these bounds placed at the right place??? I have considered that the matrix of the bounds is same as that of their respective model.

Share this post


Link to post
Share on other sites
It looks like your collision bounds are rotated off by about 90 degrees. You should look at the coordinate system that you are using and the coordinate system of the model. Many Quake2 models are actually lying "sideways" when they are imported into an OpenGL application, I've found.

Share this post


Link to post
Share on other sites

This topic is 4204 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this