• Advertisement

Archived

This topic is now archived and is closed to further replies.

wrong z-buffer??

This topic is 6209 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

ok. my problem. hmm, not easy to describe. i got a false output with multiple objekts. if two objects stand near beside the graphik gets crappy. one frame a part from the first object is seen, the next frame i can see a part of the other object. i understand it if i haven´t enabled the depth test, but i have. i also uses glDepthFunc(...) with most things. with "GL_LEQUAL" the graphik works better but almost a lot is shown wrong. does anybode have an idea how to fix these "fun"? thanks

Share this post


Link to post
Share on other sites
Advertisement
It could be because you''re using vertices that are too big. (ex. x = 500.0, y = 500.0, z = 500.0) My brother had this problem when making models. He scaled them down and solved the prob.

Share this post


Link to post
Share on other sites
make your near clip planes value as high as possible as maybe use a 24bit depth buffer

http://members.xoom.com/myBollux

Share this post


Link to post
Share on other sites

  • Advertisement