Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

ChrisE

PR4 Beta 2 DX8

This topic is 6330 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Advertisement
First bug I''ve found?

My project uses Lib archive for objects,textures etc
but won''t compile unless setlib is commented out.

error LNK2001: unresolved external symbol _setlib.

Good to have a new Beta to try!

I''ll unpack my data lib for now but maybe theres a quick
fix for this?

Thanks in advance for helping!
Petrovski

Share this post


Link to post
Share on other sites
There is a totally new way of using file archives, that allows you to use your own functions for loading files. You could use compressed archives now.

Instead of setlib, use PRLIB_OpenLibrary (file) and PRLIB_CloseLibrary().

Check out \include\support\prlibrary.h for the full list of new functions.



Share this post


Link to post
Share on other sites
Thanks for making it a bunch of little files! You don''t know how happy I am to at least have some progress after something along the line times me out (probably my ISP). I am still in the modem age...

Share this post


Link to post
Share on other sites
Thanks for the info about the new archive functions,I''ll check
those out later, since something more severe is occurring
with my setup - namely I can''t get any executable in the new
beta to get beyong the dialog box stage!

All examples crash with message
"PR_SetModeD3D"
"CreateDevice Failed"

All utilities crash with message
"createsurface for texture failed"

Any executables from PR4b1 still work so your precompiled
exes from 4b2 don''t like my setup.

I''m running a Geforce2GTS 64Mb.

my runtime drivers are DX8 retail - no debug versions installed
could this be it?

Thanks in advance for helping!
Petrovski

Share this post


Link to post
Share on other sites
And the fun begins...

Please add a line "PR_Globals.EnableLogging=1;", recompile one of the examples and send me the pr.log file it creates.

It should tell me the DX8 error code from the call that is failing.

Share this post


Link to post
Share on other sites
I get the 'CreatSurface for texture failed' error message for lstudio 4. I am wondering if it is trying to use my voodoo2 SLI rig over my GeforeMX setup? Is there any command lines I should try?

Ditto on Petroski's comments on the CreateSurface error.

General Protection shows up when I try to run them with my V2's.

No EnableLogging in PR_Globals, but there is PR_Globals.PR_DebugFlag.

Hmmm.. no debug file, as far as I can tell, has been output. There is an assert failure:

assert failure: ( g_cFGObjects ==0 ) at line 5836 of filgraph.cpp

assert failure in module Quartz.dll, 26 objects left active! At line 341 of dllentry.cpp.

This is from EX02.


Edited by - Whirlwind on February 18, 2001 4:32:51 PM

Share this post


Link to post
Share on other sites
Whirlwind,I think Chris meant:

PR_Settings.EnableLogging=1;

put this as your first line in your main().

That''s what I did & it created PR.log and I''ve sent the results to Chris.

I''m currently setting up a clean win2k partition to install
only whats needed for PR development and tomorrow I''ll
borrow a Radeon if no joy with my GF2.

Thanks in advance for helping!
Petrovski

Share this post


Link to post
Share on other sites
Got it. Sent it. The assertions were kind of neat to bring up. Thanks for the correction. I am running win98SE on a Geforce MX TwinView (yep dual monitors) with the rev 6.50 drivers.

Share this post


Link to post
Share on other sites
I get the same error as Whirlwind and Petrovski when I run the PR4 Beta2 DX8 examples. I Have a Creative 3D Blaster Annihilator (1st Generation GeForce256 SDR) graphics. I tried recompile the examples and see if they will run, but no success. I tried generating the pr.log by inserting the "PR_Globals.EnableLogging=1;", but no success. All I get is the error that EnableLogging'' : is not a member ''PR_GlobalStruct''

All of Microsofts DX8 examples from their SDK run as well as most of the PR7 examples and my own programs compiled using the PR4 Beta1.

Doug

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!