• Advertisement
Sign in to follow this  

Porting from Sharp Vodaphone to Nokia S60

This topic is 4255 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi I'm currently porting a game from a Sharp Phone over to the Nokia S60 platform. I have several issues with the compiler, as some of the tools seem to be missing and I can't set the correct directory for some paths. Attached is a snippet of codes from the batch file. <Start of codes> REM ŠÂ‹«•Ï”Ý’è set PRJNAME=mygame set CLASSPATH=C:\vodafone\c4-sdk\stubclasses;C:\tools\retroguard\retroguard.jar; REM set CLASSPATH=C:\vodafone\p5-sdk\stubclasses;C:\tools\retroguard\retroguard.jar; set MIDPBINPATH=C:\WTK\binset SOURCEDIR=source set RESOURCEDIR=resource set RELEASEDIR=release set GETFSIZE=C:\tools\getfsize.exe REM ŠÂ‹«\’z’† SET BINARY_DIR=bin SET SRCPP_DIR=source SET SRC_DIR=src SET SP_DIR=sp SET LMPRINT=C:\tools\lmprint.exe SET GETFSIZE=C:\tools\getfsize.exe SET PREPROCESSOR=C:\tools\cpp32.exe <End of codes> Does anyone have an idea of how I can get this running?

Share this post


Link to post
Share on other sites
Advertisement
What errors are you getting exactly?
And what do you want to get running in your code (I see you setting a bunch of variables but I don't see you running anything)?

Sharp Vodaphone phones have proprietary Vodaphone APIs (called VSCL) and a Nokia phone won't support those, so if our code uses them you'll have to change that.

shmoove

Share this post


Link to post
Share on other sites
Some of the classpaths are wrong, and so are some of the tools like getfsize.exe

C:\vodafone\c4-sdk\stubclasses; does not exist as well since I don't have the SDK. The exact message I get when I run the batch file is as follows:

C:\ApeReverse>REM è┬ï½ò╧ÉöÉ▌ÆΦ

C:\ApeReverse>set PRJNAME=mygame

C:\ApeReverse>set CLASSPATH=C:\vodafone\c4-sdk\stubclasses;C:\tools\retroguard\r
etroguard.jar;

C:\ApeReverse>REM set CLASSPATH=C:\vodafone\p5-sdk\stubclasses;C:\tools\retrogua
rd\retroguard.jar;

C:\ApeReverse>set MIDPBINPATH=C:\WTK22\bin
C:\ApeReverse>set SOURCEDIR=source

C:\ApeReverse>set RESOURCEDIR=resource

C:\ApeReverse>set RELEASEDIR=release

C:\ApeReverse>set GETFSIZE=C:\tools\getfsize.exe

C:\ApeReverse>REM è┬ï½ì\ÆzÆå

C:\ApeReverse>SET BINARY_DIR=bin

C:\ApeReverse>SET SRCPP_DIR=source

C:\ApeReverse>SET SRC_DIR=src

C:\ApeReverse>SET SP_DIR=sp

C:\ApeReverse>SET LMPRINT=C:\tools\lmprint.exe

C:\ApeReverse>SET GETFSIZE=C:\tools\getfsize.exe

C:\ApeReverse>SET PREPROCESSOR=C:\tools\cpp32.exe

C:\ApeReverse>REM ÅÇö⌡

C:\ApeReverse>if not exist compiled mkdir sourceconv1

C:\ApeReverse>if not exist compiled mkdir sourceconv2

C:\ApeReverse>if not exist compiled mkdir compiled

C:\ApeReverse>if not exist unverified mkdir unverified

C:\ApeReverse>if not exist verified mkdir verified

C:\ApeReverse>if not exist release mkdir release

C:\ApeReverse>SET COMPILE_DIR=compile

C:\ApeReverse>REM âvâèâvâìâZâbâT

C:\ApeReverse>SET SOURCE_EXT=java

C:\ApeReverse>SET COMPILE_EXT=java

C:\ApeReverse>DEL /Q src\*.* 1>nul
The system cannot find the file specified.

C:\ApeReverse>if not exist src mkdir src

C:\ApeReverse>C:\tools\cpp32.exe -nsrc\ source\*.java
Borland C++ Win32 Preprocessor 5.5.1 Copyright (c) 1993, 2000 Borland
source\FontScatter.java:
source\GameMIDlet.java:
source\ProcGame.java:
source\ProcLoad.java:
source\ProcRule.java:
source\ProcTitle.java:
source\reversC4.java:
source\Sprite.java:

C:\ApeReverse>REN src\*.i *.java

C:\ApeReverse>REM CD src

I know it's kinda screwed, 'cos I don't really know what I'm doing either. My job is to port the game over to a Nokia S60 platform, but I know nuts about getting the batch file to run. It seems that there are many missing tools but my supervisor (I'm doing this as a project) says that I just have to change the directories to get it working. It doesn't seem to be working for me.

Share this post


Link to post
Share on other sites
It's kind of hard to tell what the problem without knowing how your system is set up is but IMHO you should download the appropiate Nokia SDK from Forum Nokia, and I'm pretty sure there is an option to create a project from existing sources. You would probably still have to replace any proprietary code (you will be getting compiler errors if there's any).

shmoove

Share this post


Link to post
Share on other sites
I downloaded the appropriate SDK (nS60_jme_sdk_v2_6f.zip).

What it has is the Emulator, so which program do I run to create an existing project?

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement