Jump to content
  • Advertisement
Sign in to follow this  

Visual C++ Express 2005 "Application Configuration Incorrect"

This topic is 4337 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Yes, that error. I've been driven to distraction trying to figure this out. I've been working on an SDL-based game, built with Visual C++ 2005 Express. I am generating a manifest, and it runs just fine on my machine. I've tried manually redistributing the msvc?80.dll files with the game, and asking my friends to run the vcredist executable. Neither works, and the error is invariably "This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem.". Any ideas as to what I might be doing wrong? It *is* worth noting that I am developing on a 64-bit machine, but I'm building a win32 executable.

Share this post


Link to post
Share on other sites
Advertisement
I did that already. Several times. That's the problem. I followed the instructions (running vcredist on the target machines) for deploying using XCopy, and it didn't work. Is there some subtlety I might be missing?

Share this post


Link to post
Share on other sites
Your app and all .dlls used by it are linked against the release runtime?

You could try depends.exe as described here to diagnose the problem.

Share this post


Link to post
Share on other sites
Yes, I am using the multi-threaded DLL linking option (not debug DLL). And all of the libraries I'm linking to are the release versions.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!