Jump to content
  • Advertisement
Sign in to follow this  
c-only-man

configuring allegro & VS 2005 Standard

This topic is 3228 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Okay my friends: I would love a little help here. Please point me in the right direction. I am trying to get Alleg.lib linked to VS 2005 Standard. Please and thank you.

Share this post


Link to post
Share on other sites
Advertisement
This is the guide for the VS 2005 Express but it should work the same.

http://awiki.tomasu.org/bin/view/Main/VisualCExpress2005

Share this post


Link to post
Share on other sites
Breander thank you for your help however, After following the instructions it fails to compile/link. The errors I receive are:

1>------ Build started: Project: test, Configuration: Debug Win32 ------
1>Compiling...
1>main.c
1>c:\program files\microsoft visual studio 8\vc\include\allegro\internal\alconfig.h(378) : warning C4312: 'type cast' : conversion from 'unsigned int' to 'unsigned char *' of greater size
1>c:\program files\microsoft visual studio 8\vc\include\allegro\internal\alconfig.h(385) : warning C4312: 'type cast' : conversion from 'unsigned int' to 'unsigned char *' of greater size
1>c:\program files\microsoft visual studio 8\vc\include\allegro\inline\draw.inl(421) : warning C4312: 'type cast' : conversion from 'unsigned int' to 'unsigned char *' of greater size
1>c:\program files\microsoft visual studio 8\vc\include\allegro\inline\draw.inl(435) : warning C4312: 'type cast' : conversion from 'unsigned int' to 'unsigned char *' of greater size
1>c:\program files\microsoft visual studio 8\vc\include\allegro\inline\draw.inl(446) : warning C4312: 'type cast' : conversion from 'unsigned int' to 'unsigned short *' of greater size
1>c:\program files\microsoft visual studio 8\vc\include\allegro\inline\draw.inl(460) : warning C4312: 'type cast' : conversion from 'unsigned int' to 'unsigned short *' of greater size
1>c:\program files\microsoft visual studio 8\vc\include\allegro\inline\draw.inl(471) : warning C4312: 'type cast' : conversion from 'unsigned int' to 'unsigned short *' of greater size
1>c:\program files\microsoft visual studio 8\vc\include\allegro\inline\draw.inl(485) : warning C4312: 'type cast' : conversion from 'unsigned int' to 'unsigned short *' of greater size
1>c:\program files\microsoft visual studio 8\vc\include\allegro\inline\draw.inl(521) : warning C4312: 'type cast' : conversion from 'unsigned int' to 'unsigned int *' of greater size
1>c:\program files\microsoft visual studio 8\vc\include\allegro\inline\draw.inl(535) : warning C4312: 'type cast' : conversion from 'unsigned int' to 'unsigned int *' of greater size
1>Compiling manifest to resources...
1>Linking...
1>MSVCRTD.lib(crtexe.obj) : error LNK2019: unresolved external symbol _main referenced in function ___tmainCRTStartup
1>C:\Documents and Settings\Matthew\My Documents\Visual Studio 2005\Projects\test\Debug\test.exe : fatal error LNK1120: 1 unresolved externals
1>Build log was saved at "file://c:\Documents and Settings\Matthew\My Documents\Visual Studio 2005\Projects\test\test\Debug\BuildLog.htm"
1>test - 2 error(s), 10 warning(s)


Sorry for being verbose but this is really buggin me!

Share this post


Link to post
Share on other sites
Just noticed that the instructions ask me to do this.

Under Configuration Properties / Linker / Input, add alld.lib to Additional Dependencies

I dont remember seeing alld.lib.

Any ideas?

Found it in the lib directory never mind this last post.

Share this post


Link to post
Share on other sites
Hello everyone:

Still getting these errors. Please refer to the error list above and hepl as Barney Rubble would say. Wow that dates me!

Share this post


Link to post
Share on other sites
If I remeber correctly your supposed to start out with an empty project. Also make sure you downloaded the binaries for VC2005 and not the others for the other versions of VC and put them in the proper folders.

If all else fails just go over the guide line by line more then likely you skiped over something and didnt realise it.

Share this post


Link to post
Share on other sites
Mister Dave Hunt:

You da man! I was indeed using a console application and as soon as I changed to a win32 app it worked like a charm. Thank you! And to all who posted as well!

Share this post


Link to post
Share on other sites
I realize this is an old post, but I had this same problem with VS 2008. If you follow the wiki to the letter for vs 2005, and you have the binaries for VS 2008, it works perfectly.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!