Sign in to follow this  
kakum

Opal issues

Recommended Posts

I'm trying to compile ODE version 0.5 to be used with OPAL. I have downloaded and unpacked the .tgz, run the appropriate .bat file (double, with trimesh) and am trying to compile ode.sln with Visual Studio 2006. Initially, I get a bunch of link errors describing functions outlined in msvcdefs.def. I have removed t hese functions from the file, and the link errors disappear. Instead, a whole new slew of linker errors come up, unresolved external errors indicating methods such as dCollide can not be found. Is there any requisiute steps I might have omitted in installing ODE, please don't hesitate to let me know. Looming deadlines, you know? [Edited by - kakum on July 20, 2006 2:54:01 PM]

Share this post


Link to post
Share on other sites
Is 2006 even out yet? O_o.

All I did to compile it was I downloaded the source file (I think I got the zip), I opened the ode solution and built it in 2005 express.

Share this post


Link to post
Share on other sites
Whoops, 05, that is.

Thanks a bunch, that worked just fine. The instructions I was following were clearly bogus.

Unfortunately Opal is still a bit of a pain regarding... ya know, physics.

Has anyone else used this engine and had a problem where only forces applied in the y direction affect a body's position, and the effect is in the wrong direction?

Hmmm, this thread now needs a subject change.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this