Jump to content
  • Advertisement
Sign in to follow this  
EmrldDrgn

Masking problems - lesson 20

This topic is 4307 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I'm attempting to adapt the masking code from lesson 20 to my own game engine, but I can't seem to get it to work. Does masking only work if there's nothing underneath the image but its mask, or am I the one causing the problem? Based on everything I know (which is not a lot), it seems like it's me. I'll post some code in the morning, but I just wanted to post this now and see if there are any common masking issues that I should be aware of. Finally, should I be using alpha testing instead of masking to draw sprites for a game? I'm used to D3D, so I'm unsure about the correct approach in OpenGL.

Share this post


Link to post
Share on other sites
Advertisement
The correct approach is not to use masking at all.
Instead use either alpha or alphatesting.

The masking method described in lesson 20 has only a few limited uses and if you don't know exactly what those are then don't use masking.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!