Jump to content
  • Advertisement
Sign in to follow this  
imbusy

Direct3D StretchRect problem

This topic is 4350 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I have a problem with using StretchRect. Here are two shots of my application in NVPerfHUD. Explanation under the shots. As you can see in the first shot, the framebuffer is all ok. In the second shot, if you look at the sampler in the top left corner, it's off by a pixel. This is the result of StretchRect. Does anyone have any idea what the cause of this might be? I'm using Nvidia Geforce 6600GT. I've noticed different results on other hardware (I think Intel 915GM chipset), which were ok.

Share this post


Link to post
Share on other sites
Advertisement
You should try running it in the reference rasterizer to see if it is a driver bug (which i certainly hope it is not, I've been using stretchRect on nv cards for a long time).

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!