Sign in to follow this  
phi

FMOD with VC++

Recommended Posts

I'm using VC++ 2005 express edition. I've created a new project ( a win32 console project) and I want to use FMOD. However, when I try and compile my code, I keep getting "error LNK1029". This occurs during the linking process, so I assume it's because I haven't manually linked "fmod_vc" object library. However, I'm not sure how I do this. I went to project...properties, but can't find anywhere where I can manually select "fmod_vc". I used to use dev-C++ but the FMOD c++ interface isn't the easiest thing to set up with that since it's a non-MS compiler. Any ideas what I'm doing wrong? Thanks

Share this post


Link to post
Share on other sites
You should have a dedicated line in the project options (in the linker/input part - I don't recall it since I haven't used VS2005 for month). Another possibility is to add the library to your project files (yes, you can do this). A third possibility is to add a #pragma comment(lib, "library_path") into one of your source file.

HTH,

Share this post


Link to post
Share on other sites
Quote:
Original post by Emmanuel Deloget
#pragma comment(lib, "library_path")

I much prefer this option, because it documents the linking of the library in your source code.

However, this is, as far as I know, VC-specific. So, I usually surround my library links with #ifdef WIN32

#include <libname.h>
#include <otherlibname.h>

#ifdef WIN32
#pragma comment(lib, "libname.lib")
#pragma comment(lib, "otherlibname.lib")
#endif


Also, if you prefer linking through the IDE like a normal person (not me), I believe it's Project->Linker, then one field on the right should be "Linker Input". You may also have to put "additional library include directories" in the project settings, or the IDE settings if you want it for all projects at your workstation.

Share this post


Link to post
Share on other sites
Thanks for the help. The last two methods worked, but I can't find the option to add it under "Project". I go to the properties page....configuration properties...Linker but can't find anywhere to choose a specific library. Closest thing I can find is "Additional Library Directory".
However, as I said, the previous two methods worked. Although the program runs I get a lot of "No symbols loaded" messages in the output window and they refer to DLL files in the "Windows\System32" directory. I'm assuming this isn't a problem, since the actual program works fine.
Thanks again for the help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this