Sign in to follow this  

[.net] PropertyGrid : different behavior between Windows Vista and XP ?

This topic is 4092 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi again, This time it's a question about the PropertyGrid ^^ I was coding a little app under Windows Vista, and in this app, I have a property grid. I wanted to be able to sort the properties as I want. So, after a few minutes of googling, I found out that adding \t before the display names of my properties worked. For example : [DisplayName("\t\tThis is displayed First")] property String ^ ThisIsDisplayedFirst; [DisplayName("\tSecond")] property String ^ Second; Works, and the \t is not displayed. That not really an intuitive way of sorting my attributes, but it worked. But unfortunately, when I switched back to Windows XP, I wanted to try that on another project, and I didn't work ... it's sorted, but \t is displayed as a black rectangle ... Do you know why ? Is it a font problem ? I think so, but I'm not sure. Thx in advance for any help.

Share this post


Link to post
Share on other sites

This topic is 4092 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this