Jump to content
  • Advertisement
Sign in to follow this  
maverick20

OpenGL Why am i getting this error--GLUT

This topic is 4369 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi...just wanted to ask that why the hell am i getting this error... ------ Build started: Project: GLUT, Configuration: Debug Win32 ------ Linking... MSVCRTD.lib(crtexew.obj) : error LNK2019: unresolved external symbol _WinMain@16 referenced in function ___tmainCRTStartup D:\Visual Studio 2005\MyProjects\OpenGL\GLUT\Debug\GLUT.exe : fatal error LNK1120: 1 unresolved externals Build log was saved at "file://d:\Visual Studio 2005\MyProjects\OpenGL\GLUT\GLUT\Debug\BuildLog.htm" GLUT - 2 error(s), 0 warning(s) ========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ========== Is there anything wrong with glut??or its paths..if it is so, please help me out and also provide a link from where i can get GLUT, the latest...or any previous versions...thnx

Share this post


Link to post
Share on other sites
Advertisement
You need to create a Win32 Console Project, not a Win32 Project.

The entry point for a Win32 project is the WinMain function. Since you don't have one, the linker is complaining. The entry point for a console application is the main function which (I assume) you have.

Hope that helps.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!