Sign in to follow this  
maverick20

OpenGL Why am i getting this error--GLUT

Recommended Posts

Hi...just wanted to ask that why the hell am i getting this error... ------ Build started: Project: GLUT, Configuration: Debug Win32 ------ Linking... MSVCRTD.lib(crtexew.obj) : error LNK2019: unresolved external symbol _WinMain@16 referenced in function ___tmainCRTStartup D:\Visual Studio 2005\MyProjects\OpenGL\GLUT\Debug\GLUT.exe : fatal error LNK1120: 1 unresolved externals Build log was saved at "file://d:\Visual Studio 2005\MyProjects\OpenGL\GLUT\GLUT\Debug\BuildLog.htm" GLUT - 2 error(s), 0 warning(s) ========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ========== Is there anything wrong with glut??or its paths..if it is so, please help me out and also provide a link from where i can get GLUT, the latest...or any previous versions...thnx

Share this post


Link to post
Share on other sites
You need to create a Win32 Console Project, not a Win32 Project.

The entry point for a Win32 project is the WinMain function. Since you don't have one, the linker is complaining. The entry point for a console application is the main function which (I assume) you have.

Hope that helps.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this