Jump to content
  • Advertisement
Sign in to follow this  
aamishah

OpenGL OpenGL Blending Issue with Bitmap Fonts

This topic is 4369 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hello Gurus! I Got a Blending Issue in OpenGL. I am using Transparent PNG images for my Bitmap Fonts. it has soft(semi-transparent) shaodws. [sad] But when I enable Blending, I get a diagonal line passing through the Quads (as if it was a Triangle strip). As you can see in this Picture, Fonts appear to be slashed ,same effect can be seen in Logo. Without Blending I get Hard edges, following pic uses AlphaTesting but obviously, its not as sweet as blending. I have tried many things like BackFace Culling, Disable Light, Disable DepthTest, Depth Masking, PolygonModes and so on. Please Help[help]. Here is a Sample Code,I am using Tao Framework in VB.NET:
glBlendFunc(GL_SRC_ALPHA, GL_ONE_MINUS_SRC_ALPHA)

glDisable(GL_DEPTH_TEST)
glEnable(GL_TEXTURE_2D)
glEnable(GL_BLEND)

DrawFont()

glEnable(GL_DEPTH_TEST)
glDisable(GL_TEXTURE_2D)
glDisable(GL_BLEND)


[Edited by - aamishah on October 7, 2006 9:47:15 AM]

Share this post


Link to post
Share on other sites
Advertisement
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!