Jump to content
  • Advertisement
Sign in to follow this  
Wavesonics

FTGL linking problem that may just kill me

This topic is 4417 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I've been struggling with linking, compiler errors with different OpenGL font rendering libraries for days now. It is threatening to strip me of my sanity. Here is the current state of things. I don’t have a linux system I can reliable compile / test on. So I have to find static linked libs usually. So I downloaded FTGL, included the header file, and linked to freetype and libftgl.a and I get an undefined reference to the FTGLBitmapFont constructor. So I downloaded the ftgl_static_ST.lib and tried linking to that, no change. Does any 1 have any idea what the hell could be the problem? My linking order is: ftgl freetype OpenGL32 Um... I'm just kinda out of ideas... This is the line thats throwing the undefined refrence:
Quote:
font = new FTGLBitmapFont( "data/fonts/ALEXEI.TTF" );
but the next line:
Quote:
font->FaceSize( iPointSize );
isn't complaining... Any help at ALL would be GREATLY appricated. I'm using Code::Blocks btw.

Share this post


Link to post
Share on other sites
Advertisement
I'm not sure, but I think the issue may be that the static lib I found and am linking too is an older version of the lib.

Does any one have a static lib for FTGL 2.1?

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!