• Advertisement
Sign in to follow this  

doxygen doesn't document code in cpp file. [fixed]

This topic is 4129 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi. I hope someone can help me with this problem. I decided to use doxygen for source documentation. Everything works just fine, but when I place a description of a function, or more precisely, a desc of a member function, into a .cpp file instead of the .h file, doxygen no longer extracts that description into the .html file. But in the .h file, it works. In the manual, it says, that it is possible, and there is no flag which I have to set. It just says, that it is possible to put that kind of desc into the definition file instead of the declaration file. Hopefully someone can help me. Because just the function tree without the in source description makes no sense. Thanks Alex [Edited by - directNoob on October 18, 2006 2:22:01 PM]

Share this post


Link to post
Share on other sites
Advertisement
In your .dox file, there is a flag called "FILE_PATTERNS" and that's where you list the file extensions you want doxygen to look at...as well as the paths by using the "INPUT" flag. Here's mine:

Quote:


FILE_PATTERNS = *.cpp *.inl *.h


Hope that helps!

Share this post


Link to post
Share on other sites
Sorry, but your first solution doesn´t work.

But what I can say is that the .cpp files are listed in the window which gets filled in the wizard, when the wizard recursivly traverse through the file tree.

But thanks.
There must be another flag. But it´s not mentioned in the manual, which I have read!!!

Alex

[Edited by - directNoob on October 18, 2006 1:15:48 PM]

Share this post


Link to post
Share on other sites
There are many, many possible configurations in Doxygen, so make sure you understand all the settings by reading the manual.

Off the top of my head, if the above fix didn't work as you say, my guess would be that your "private documentation" setting is set incorrectly. IIRC, when "private documentation" is on, Doxygen only documents the public files (IE -- the header files.) However its been about a year since I last created a new doxygen configuration, so I could very well be wrong. Try it, if it works - great; otherwise, rest assured that it *is* some setting somewhere.

Share this post


Link to post
Share on other sites
Ok, everything works right now. I'm happy.
I mean, doxygen is great, its all about the user wether it works or not.

The problem was this:
I used this documentation style: /*! ... */
This works in the header file, but the cpp file needs this style: /** ... */
I understood the manual as that I´m allowed to use the notation as I want...

And by the way, the doc also says, that doxygen uses .cpp and .h by default for small project. Small projects??? Please define small projects... :?

Anyway, thanks for sharing your time with my and my problem...

Reading you
Alex

Share this post


Link to post
Share on other sites
I find it hard to believe that the problem was using /*! in one place and /** in another (but I have never tested it so what do I know). Perhaps the problem is that you don't use @file in the cpp files. In order to document global objects (functions, typedefs, enum, macros, etc), you must document the file in which they are defined.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement