• Advertisement
Sign in to follow this  

prevent light from effecting texture

This topic is 4122 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Basically I want to draw something to the screen but have it uneffected by any lights. How would I go about doing this?

Share this post


Link to post
Share on other sites
Advertisement
I'm drawing a scene in 3D using ortho projection, wich uses DX's fixed function lighting. And I want to have overlays over everything that arn't effected by the lighting.

Should I turn off the lights right before I draw the overlays?

Share this post


Link to post
Share on other sites
Careful, I did not say turn off lights. If you do that and leave lighting enabled, then everything would be black. You must simply disable lighting, that is the important part. And yes, disable it before you draw your overlaid items.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement