Jump to content
  • Advertisement
Sign in to follow this  
wasd

Release not deleting objects

This topic is 4413 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I'm calling release on some objects, and the release function is returning 0 (there are no more references on the object), but the objects are not being automatically deleted. They should be deleted even if they are set on the device, right? Or do I have to unser everything before calling release?

Share this post


Link to post
Share on other sites
Advertisement
If a resource is bound to the pipeline its reference count will be increased (this changes with D3D10), so yes - you will need to unbind it before it will actually be deleted.

Also bare in mind that the return value from Release() is not required to be accurate - whilst it might correspond to the real reference count there is no guarantee. I've managed to trip up leak-detection software with this sort of thing [wink]

hth
Jack

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!