Jump to content
  • Advertisement
Sign in to follow this  
GenuineXP

[java] [solved] Help! Eclipse can't resolve 'Scanner'! Why?!

This topic is 4409 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I recently formated my hard drive(s) and started my system from scratch. I installed Eclipse and the J2RE. I opened a Java project that, as far as I knew, contained no errors, but it didn't run. I looked in the problematic file and found that is couldn't resolve Scanner objects! I have import.java.util.*; at the top of the file. Why can't it find Scanner?! I need to do some finishing touches on a project and have no idea why this is happening! Any ideas? Thanks! I really need some help here.

Share this post


Link to post
Share on other sites
Advertisement
Phew! Turned out I had an older version of the Java runtime installed and it was "confusing" Eclipse. As soon as I removed it everything worked just fine. Sorry 'bout that; I need to get this work done. :-D

Share this post


Link to post
Share on other sites
You can select which JRE to use, both for an entire workspace via the global preferences and for individual projects via project properties. It's actually useful to have multiple JREs installed for testing.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!