Jump to content
  • Advertisement
Sign in to follow this  
bionic_atom

Amaltheia library C++ error

This topic is 4330 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi, me again. I was told to go to SDK and use a libary so I did. so I downloaded Amaltheia library for C++ extracted it; and believe I told me compiler how to link to it through project options. But im getting these errors 1 C:\Documents and Settings\c.s. finch\Desktop\C++ Files\mainA_withALIBRARY.cpp amaltheia/Graphics.h: No such file or directory. 2 C:\Documents and Settings\c.s. finch\Desktop\C++ Files\mainA_withALIBRARY.cpp amaltheia/Input.h: No such file or directory. 3 C:\Documents and Settings\c.s. finch\Desktop\C++ Files\mainA_withALIBRARY.cpp amaltheia/Sprite.h: No such file or directory. So, it looks like with these errors my project isn't linked to the Amaltheia library, so How do I link it up with Dev C++ 5.0(beta)? Any help will useful. Thanks, c.s. finch

Share this post


Link to post
Share on other sites
Advertisement
Linking with a library is different to being able to include header files.

At the moment, your problem is that the header files aren't being included because they can't be found. All you can really do with that is just make sure that the files are where you think they are, and make sure that the directory path you give it is correct.

If that doesn't work, most IDE's have a set of directories that are the default directories that it searches for header files. It probably won't be under Project Preferences, more likely look for it under the IDE's options window.

Anyway, if you add it like that, just include the files like so:

#include <Graphics.h>
#include <Input.h>
#include <Sprite.h>


And if that doesn't work, you've really got some problems.

P.S. Linking with a library is when a program gets the correct addresses stored of functions that are stored in a ".lib" or ".dll" file.

Edit:: And just to be sure, don't mix '/' and '\' in a single directory path. Just use one or the other. I'm not sure if it makes a difference, but, to me at least, it is less confusing seeing only the one.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!