Sign in to follow this  
JohnHurt

Nastyroids 3D v1.1

Recommended Posts

After about a year on the shelf, I decided to dust this project off today. This game has never been able to run on nVidia cards, but I upgraded to nVidia recently, so thought I'd have a stab at sorting it out. I did it! Anyway, for those who've forgotten what it is I threw together a short video of it which is here. You can download it here. I may at some point do a new and improved version of this, so suggestion of what to add would be cool. Thanks guys.

Share this post


Link to post
Share on other sites
Agreed on the mouse sensitivity point, but you get used to it fairly quickly.

Quite an amusing game, especially with the nice explosions.

Share this post


Link to post
Share on other sites
This looks awesome (seriously, most Asteroid clones look bad), I want to try out because I've always been a huge asteroids fan.

I just extracted it to a folder and it failed to run. No error messages, just get the hour glass for a split second and nothing happens.

Running WinXP Pro.

Any ideas?

Share this post


Link to post
Share on other sites
Thanks for the feeback guys. A mouse sensitivity adjuster was always something I meant to add, so that will definitely be in version 2!

--dumptruck - No idea what that error could be. I know I've had that happen to me on a few different programs from time to time, and a reboot always cures it. Not sure if its still related to the old nVidia bug the game had, but if your on nVidia, make sure you have the latest drivers, 'cos that's all I've tested on. Apart from that, no idea. Let me know if you have any luck at all.

[edit] - Just thought - did the little setup prog run at all? If it didn't then run that first (nr3dconfig.exe), the game needs to see config.nrs in order to run. It should run the setup automatically if it doesn't find the file.

Share this post


Link to post
Share on other sites
Sorry to see you're having problems. Until I can get to a machine it doesn't work on there's not a lot I can do about it unfortunately. For those who can't run it, please could you tell me your system specs.

[edit] - I just uploaded a modified version which includes slightly better error logging. So you should see some text in the "applog.log" file now.

[Edited by - JohnHurt on November 26, 2006 2:16:36 PM]

Share this post


Link to post
Share on other sites
Hi guys,

I believe I've solved the issue now, which was related to the program requiring the Visual C++ 2005 Redistributable to be installed. I've taken this dependency out now by recompiling in VC2003. The new version is at the same link now.

Share this post


Link to post
Share on other sites
Right, fingers crossed I've now solved the DLL nightmare by statically linking the config program with MFC. If it doesn't work for everyone now I give up! I refuse to make an installer - unless someone else wants to volunteer for that job!

Share this post


Link to post
Share on other sites
Sign in to follow this