Jump to content
  • Advertisement
Sign in to follow this  
Icebraker

Problem with FBOs

This topic is 4253 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi, I"m trying to get Framebuffer-objects running for my project. I"ve programmed to following code so far(i ist size of the image): glGenFramebuffersEXT(1, &fbId); glGenRenderbuffersEXT(1, &renderId); glGenTextures(1, &texId); glBindFramebufferEXT(GL_FRAMEBUFFER_EXT, fbId); glBindRenderbufferEXT(GL_RENDERBUFFER_EXT, renderId); glBindTexture(GL_TEXTURE_2D, texId); glRenderbufferStorageEXT(GL_RENDERBUFFER_EXT, GL_RGB32F_ARB, i, i); glFramebufferRenderbufferEXT(GL_FRAMEBUFFER_EXT,GL_RGBA8,GL_RENDERBUFFER_EXT,renderId); glFramebufferTexture2DEXT(GL_FRAMEBUFFER_EXT,GL_COLOR_ATTACHMENT0_EXT,GL_TEXTURE_2D,texId,0); checkFBO(glCheckFramebufferStatusEXT(GL_FRAMEBUFFER_EXT)); However, glCheckFramebufferStatusEXT does not return GL_FRAMEBUFFER_COMPLETE_EXT. According to glxinfo my Card/System does support the FBO extension and no errors occur at compiletime. Did I forget some important commands to setup the framebuffer? Thx, Icebraker

Share this post


Link to post
Share on other sites
Advertisement
glCheckFramebufferStatusEXT() returns 0, which does not seem to match any of the constants from the spec... What does a returnvalue of 0 imply?

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!