Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

gt6081a

Texture mapping

This topic is 6368 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hello everyone. I am having a weird problem with some texture mapping I am doing. I am making a game, a scrolling shooter game. Anyway, when I map a texture to the ground....all the other 3d objects get the color of the texture. If yu want to see my source so far, icq me at 54272200. Thanks for your help! Eric

Share this post


Link to post
Share on other sites
Advertisement
Are you drawing the un-textured polygons with flat colours? If so, did you remember to disable textures when drawing them?

Share this post


Link to post
Share on other sites
The other objects are using material properties. What caommand disables textures, I may just diasble them after I draw the ground for a quick fix if need be.

Eric

Share this post


Link to post
Share on other sites
glDisable(GL_TEXTURE_2D)
should do it.
However, it might be faster(not sure) to create a white texture and bind that one instead. Might be worth looking into.

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!