Jump to content
  • Advertisement
Sign in to follow this  
Journey

Win32 API - Showing List View as a grid

This topic is 4162 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I just used the LVS_EX_GRIDLINES extended style in my list view control but I don't see a grid dividing the items. I inserted several items but there's no grid between them. What could be wrong?

Share this post


Link to post
Share on other sites
Advertisement
Is your list view an LVS_REPORT? To set the style you used ListView_SetExtendedListViewstyleEx() or equivalent (that is, not in CreateWindowEx())?

Share this post


Link to post
Share on other sites
It turns out that setting the extended style works for LVS_EX_FULLROWSELECT for example, if I select an item the whole row gets selected. The funny thing is that I see a line separating the item from the subitem, but it's white. I don't know if this is the grid that is being displayed in the same color as the background, this would be foolish. Could it be possible that the grid is getting displayed by default in the same color as the background? Shouldn't it be black? (And I'm not changing the background color btw)

And also, I tried ListView_SetExtendedListViewstyleEx and SendMessage. But the result is still the same.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!