Jump to content
  • Advertisement
Sign in to follow this  
ibr_ozdemir

problem about "allocing memory"

This topic is 4253 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

hi, i'm making my own simple game engine and i'm using primitiveUP for drawing the language that i use is Delphi 6, and i'm filling vertexbuffers (not IDirect3DVertexBuffer9, my own vertexbuffer variant) with ReallocMem, and i read about ReallocMem that : if i use it so much than cause "memory fragment" so i tried GetMem and GetMemory and doesnt change any thing THERE IS NO SOMETHING (TRIANGLE) IN THE SCENE. when i use IDirect3DVertexBuffer9 its working but i dont want to change my engine its so difficult for me (also if i cant find any solution i have to change it) anyway how can i make vertexbuffer that primitiveUP support, does it have to static memory block because ReallocMem create Dynamic memory block thanks

Share this post


Link to post
Share on other sites
Advertisement
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!