Jump to content
  • Advertisement
Sign in to follow this  
TheFakeCow

Mesh Alpha Blending Problems

This topic is 4339 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hello All, I'm having a bit of a problem rendering transparent meshes. weird It's easier to see what is going on in the purple circle. If you notice, the outermost ring should be transparent, and we should be able to see the rest of the "Orb/Avatar" through it. Instead we can see all the way through the rest of the mesh. I am drawing this as a single, animated, mesh in the latest DirectX with pixel/vertex shaders. I assume this has to do with the draw order within the meshes themselves, but I am at a loss as to how to fix it. I am hoping someone here has overcome this problem already, and can point me in the right direction. Thanks for your time, Eric Walker Ominous Development www.ominousdev.com

Share this post


Link to post
Share on other sites
Advertisement
You should try to render the object's backfaces first and then render the front faces. Also don't forget to turn of depth testing before you render the transparent objects and use additive blending where you can.

Just a quick thought,
Jeroen

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!