Sign in to follow this  

How do I keep KDE from starting up?

This topic is 3932 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hello, I am in class here using Debian Linux, and its been a while since I have used linux and I used to have my linux set up for command line login and I would be able to just "starx" and hav it load X with an Xterm(no window manager yet) and then punch "fbrun &" into the xterm window there and it would load fluxbox(I love fluxbox). Now, after this new install of Debian I got the command line login working, but when I punch in "startx" it will load X, then automatically load Gnome. I thought an easy answer to that would be uninstall Gnome(I hate gnome) so I did that, but now it automatically jumps to KDE. I would like to keep KDE though because I use a lot of the KDE programs with fluxbox. I looked through the xconfig files and couldn't find a line where it was starting KDE or Gnome. Oh, and I went back to the graphical login and changed the default login to FluxBox but going into the command line login and starting X again will load KDE by default instead of Fluxbox. So, basically, what config file will I have to look at that will allow me to change the default window manager? Thanks, rating++ to anyone who helps :D

Share this post


Link to post
Share on other sites
If you can edit the grub.conf file. Should be in /boot/grub/grub.conf or something like that. There should be a line similar to the following (mine if from Fedora but the line should be very similar).

title Fedora Core (2.6.19-1.2288.fc5smp)
root (hd0,0)
kernel /vmlinuz-2.6.19-1.2288.fc5smp ro root=/dev/VolGroup00/LogVol00 rhgb quiet 5







Notice the 5 at the end. Just copy that entire section and paste it right below. Change the title to display that it is the command line option and then change the 5 to a 3.


title Fedora Core (2.6.19-1.2288.fc5smp)
root (hd0,0)
kernel /vmlinuz-2.6.19-1.2288.fc5smp ro root=/dev/VolGroup00/LogVol00 rhgb quiet 5

title Fedora Core (2.6.19-1.2288.fc5smp) - Command Line
root (hd0,0)
kernel /vmlinuz-2.6.19-1.2288.fc5smp ro root=/dev/VolGroup00/LogVol00 rhgb quiet 3






Here are the 6 runlevels supported.

1 System Halted
1 Single User Mode
2 Single User Mode with Networking
3 Multi-User Mode - boot up in text mode
4 Not yet Defined
5 Multi-User Mode - boot up in X Windows
6 Shutdown & Reboot

[Edited by - tstrimp on March 5, 2007 10:18:58 AM]

Share this post


Link to post
Share on other sites
Ok, found it, but mine looks like this:

title Debian GNU/Linux, kernel 2.4.27-3-686
root (hd0,0)
kernel /vmlinuz-2.4.27-3-686 root=/dev/hda2 ro
initrd /initrd.img-2.4.27-3-686
savedefault
boot


should I just tack "quiet 3" onto the end of the "kernel" line? and put Command Line into the title?

Share this post


Link to post
Share on other sites
Thanks man.

EDIT: Well, that didn't work. What worked was using xinit instead of startx. I wasn't doing that because it was giving me some error like.. "Xterm is not in your path"... I was going crazy about that because /bin was in my path and thats where it should have been, until I noticed it wasn't even installed, fixed that and now I can use xinit which does not automatically start KDE/Gnome.

Thanks though.

[Edited by - lethalhamster on March 5, 2007 5:47:11 PM]

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
you know you could just edit your .xinitrc in your home directory right? It is the script that startx uses to initialize X. You really should call startx instead of xinit.

Share this post


Link to post
Share on other sites
Sign in to follow this