Jump to content
  • Advertisement
Sign in to follow this  
CrimsonMemory

OpenGL Having trouble setting up OpenGL with VC++ 2005

This topic is 4148 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I'm sure I'm missing something really obvious, but I can't seem to figure out what. When I compile my test program, the compiler flags more than 100 errors in gl.h, and none in my actual program. Are there any sort of flags I should set in order for VC++ to compile gl.h correctly? I'd post code, but the only errors reported are in gl.h. Thanks in advance!

Share this post


Link to post
Share on other sites
Advertisement
you need to add the lib files to your compiler also.

glaux.lib glu32.lib opengl32.lib

under linker->input

Share this post


Link to post
Share on other sites
Okay, I just found out that I had to include <windows.h> before gl.h - strangely, I only found this out by scouring the internet for a similar problem. Why isn't it mentioned in most tutorials (Windows-specific ones, even!) that this is necessary? Oh well.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!