Sign in to follow this  

Dev-Cpp stops compiling

This topic is 3931 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi guys! Actually this doesn't happen only with dev-cpp but to mingw itself. I'm just wondering since in my machine which has 512MB of RAM and another which has 192MB this doesn't happen. However, here in my office machine which has a 2GB RAM, the compiler would start then hang for the rest of its life. This also happened before I upgraded to 2GB, before I only had 1GB. I already formatted the PC and reinstalled Dev-Cpp(even downloaded another one). I have lots of other IDE's here and this only happens with dev-cpp so far..

Share this post


Link to post
Share on other sites
What phase of the build is it hanging on? Try to run your build manually from the command line and see what happens (g++, etc.) Also, check if the process is eating up all the memory/CPU, or if it's just sitting there. In Windows, looking at it on task manager might be all you need to do. In Linux, top, ps and strace (and a few others) are your friends.

Also, you mentioned this is your work computer. Is it possible that they just block some things from running?

Share this post


Link to post
Share on other sites

This topic is 3931 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this