Jump to content
  • Advertisement
Sign in to follow this  
PlutoWarrior

Problem with lesson 19 under linux w/ GLX

This topic is 4258 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I just downloaded lesson 19 from nehe's site and I ran into a problem when running it. It gives me the following error which I've done multiple google searches on with no help in fixing it. I heard it's a memory problem but I'm not sure what or how to correct this, considering I didn't write or edit the code. Here are the errors: Error: number of Planes not 1! *** glibc detected *** ./lesson19: double free or corruption (out): 0x00002b4b35c4fe20 *** This is also outputed in the crash.
======= Memory map: ========
00400000-00405000 r-xp 00000000 08:06 1733351                            /home/paul/src/opengl/lesson19/lesson19
00504000-00505000 rw-p 00004000 08:06 1733351                            /home/paul/src/opengl/lesson19/lesson19
00505000-006e8000 rw-p 00505000 00:00 0                                  [heap]
2b4b354b0000-2b4b354cc000 r-xp 00000000 08:05 114468                     /lib/ld-2.4.so
2b4b354cc000-2b4b354d0000 rw-p 2b4b354cc000 00:00 0 
2b4b355cb000-2b4b355cd000 rw-p 0001b000 08:05 114468                     /lib/ld-2.4.so
2b4b355cd000-2b4b3566a000 r-xp 00000000 08:05 725499                     /usr/lib/libGL.so.1.2
2b4b3566a000-2b4b3576a000 ---p 0009d000 08:05 725499                     /usr/lib/libGL.so.1.2
2b4b3576a000-2b4b3578a000 rw-p 0009d000 08:05 725499                     /usr/lib/libGL.so.1.2
2b4b3578a000-2b4b35790000 rw-p 2b4b3578a000 00:00 0 
2b4b35790000-2b4b3580e000 r-xp 00000000 08:05 720945                     /usr/lib/libGLU.so.1.3.060501
2b4b3580e000-2b4b3590d000 ---p 0007e000 08:05 720945                     /usr/lib/libGLU.so.1.3.060501
2b4b3590d000-2b4b3590f000 rw-p 0007d000 08:05 720945                     /usr/lib/libGLU.so.1.3.060501
2b4b3590f000-2b4b35914000 r-xp 00000000 08:05 721027                     /usr/lib/libXxf86vm.so.1.0.0
2b4b35914000-2b4b35a13000 ---p 00005000 08:05 721027                     /usr/lib/libXxf86vm.so.1.0.0
2b4b35a13000-2b4b35a14000 rw-p 00004000 08:05 721027                     /usr/lib/libXxf86vm.so.1.0.0
2b4b35a14000-2b4b35b4a000 r-xp 00000000 08:05 114522                     /lib/libc-2.4.so
2b4b35b4a000-2b4b35c4a000 ---p 00136000 08:05 114522                     /lib/libc-2.4.so
2b4b35c4a000-2b4b35c4d000 r--p 00136000 08:05 114522                     /lib/libc-2.4.so
2b4b35c4d000-2b4b35c4f000 rw-p 00139000 08:05 114522                     /lib/libc-2.4.so
2b4b35c4f000-2b4b35c55000 rw-p 2b4b35c4f000 00:00 0 
2b4b35c55000-2b4b35d2f000 r-xp 00000000 08:05 720972                     /usr/lib/libX11.so.6.2.0
2b4b35d2f000-2b4b35e2e000 ---p 000da000 08:05 720972                     /usr/lib/libX11.so.6.2.0
2b4b35e2e000-2b4b35e33000 rw-p 000d9000 08:05 720972                     /usr/lib/libX11.so.6.2.0
2b4b35e33000-2b4b35e43000 r-xp 00000000 08:05 720991                     /usr/lib/libXext.so.6.4.0
2b4b35e43000-2b4b35f43000 ---p 00010000 08:05 720991                     /usr/lib/libXext.so.6.4.0
2b4b35f43000-2b4b35f44000 rw-p 00010000 08:05 720991                     /usr/lib/libXext.so.6.4.0
2b4b35f44000-2b4b35f55000 r-xp 00000000 08:05 114945                     /lib/libpthread-2.4.so
2b4b35f55000-2b4b36054000 ---p 00011000 08:05 114945                     /lib/libpthread-2.4.so
2b4b36054000-2b4b36056000 rw-p 00010000 08:05 114945                     /lib/libpthread-2.4.so
2b4b36056000-2b4b3605b000 rw-p 2b4b36056000 00:00 0 
2b4b3605b000-2b4b3605d000 r-xp 00000000 08:05 114634                     /lib/libdl-2.4.so
2b4b3605d000-2b4b3615d000 ---p 00002000 08:05 114634                     /lib/libdl-2.4.so
2b4b3615d000-2b4b3615f000 rw-p 00002000 08:05 114634                     /lib/libdl-2.4.so
2b4b3615f000-2b4b36245000 r-xp 00000000 08:05 721657                     /usr/lib/libstdc++.so.6.0.8
2b4b36245000-2b4b36344000 ---p 000e6000 08:05 721657                     /usr/lib/libstdc++.so.6.0.8
2b4b36344000-2b4b3634a000 r--p 000e5000 08:05 721657                     /usr/lib/libstdc++.so.6.0.8
2b4b3634a000-2b4b3634d000 rw-p 000eb000 08:05 721657                     /usr/lib/libstdc++.so.6.0.8
2b4b3634d000-2b4b3635f000 rw-p 2b4b3634d000 00:00 0 
2b4b3635f000-2b4b363df000 r-xp 00000000 08:05 114635                     /lib/libm-2.4.so
2b4b363df000-2b4b364de000Aborted (core dumped)

Share this post


Link to post
Share on other sites
Advertisement
Hi, I just try the same, remotely, and it's work for me (I have a Debian Testing box with Athlon MP2200 *2 and nvidia GeForce4MX440 with nvidia drivers 1.0.8776-4) Also SDL is ok.
Such error like one you got is typically linked to broken system (missing dependancies, bad library used, or more critical: memory failure, this one lead to random error with any memory consumming software).

So without further information, we can't help you. Which are your host system, gfx card, drivers release, any other 3D app work ? ...

Share this post


Link to post
Share on other sites
Yea, I probably should have included more information. I'm sorta new with linux in general. I'm running Ubuntu 6.10 64bit version.

Here the info when I run fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON X800 GTO Generic
OpenGL version string: 2.0.6011 (8.28.8)

I've gotten other simpler nehe tutorials to run without issues like the rotating cubes. I know there probably other information you need I'm just not too sure how to get it.

Share this post


Link to post
Share on other sites
I've not paid attention to error message from code, it is in loadBMP sub, if number of bitplanes read is not 1. Perhaps your image file is corrupted leading to further issues.
But again, check your memory too (take a look at memtest86+ for deeper test, but a mere kernel compilation should give you a hint about memory health, ie if random error occur while compiling)

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!