Sign in to follow this  
huaner

access conflict when glCreateShaderObjectARB

Recommended Posts

Hi: this is my first glsl framework.unfortunatly, it happened the mistake of accessing conflict. so i tracked it, i found when got the function of glCreateShaderObjectARB, it happened. my codes as fellow:
GLhandleARB v,f;
v = glCreateShaderObjectARB(GL_VERTEX_SHADER_ARB);
f = glCreateShaderObjectARB(GL_FRAGMENT_SHADER_ARB);
thank you very much!

Share this post


Link to post
Share on other sites
Are you loading the Extensions yourself, or do you use a library like GLee or GLEW ?

I had the same problem when i tried to load the extensions myself, using GLee solved the Problem.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this