Jump to content
  • Advertisement
Sign in to follow this  
dali

February 2007 Microsoft Direct X Sdk - Strange input behaviour

This topic is 4056 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hello I wished I had never switched to the February 2007 Microsoft Direct X Sdk 3 days ago :D After changing some methods for text drawing and sprite drawing (changed the parameters and added for each sprite a begin and end because otherwise the sprites would not display in the new Sdk) I now encounter a really strange input behavior. Everything seems so jerky although I even have a little bit better fps. The input is always a little bit behind and I absolutely have no clue from where this comes from because I have not changed a single bit of other code. Has anyone encountered this before I would really appreciate some hint! Thanks a lot

Share this post


Link to post
Share on other sites
Advertisement
No i dont use dinput. The main loop is bellow but i cannot believe this is the problem:


while (m_bRunning)
{



if (PeekMessage(&msg,0,0,0,PM_REMOVE))
{
if (msg.message == WM_QUIT)
break;

TranslateMessage(&msg);
DispatchMessage(&msg);
}
else
{
...
}
}

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!