Jump to content
  • Advertisement
Sign in to follow this  
RayTracer

[solved] VMR9 Device Reset Problem

This topic is 4072 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hello , i'm using VMR9 to render video files on 3D surfaces but when i try to reset the device in the case of a Device Lost i get an invalidcall error.I've released all the surfaces and have no idea why reset fails.Thanks [Edited by - RayTracer on May 18, 2007 5:09:28 AM]

Share this post


Link to post
Share on other sites
Advertisement
If you switch to the Debug DirectX driver (you can do this in the DirectX control panel), then the debug log will tell which resources have not been released. Also, if it's possible, then make your resources managed, and DirectX will take care of this for you.

Share this post


Link to post
Share on other sites
Hi, I am having the same problem you had. I am using the custom allocator sample to show video and when changing the window size trying to reset the device ( after calling DeleteSurfaces ) and apperentlly there is still some 3 resources that are not freed ( its look like they ware allocated by the graph ). any leads of where did you find those resources or how should I tell the graph to release those resources ???
Thanks

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!