Sign in to follow this  

JUST IMPLEMENT REFLACTION AND EVERYTHING GOES SLOW(1 FPS)

This topic is 3863 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I download from nehe:reflection turorial,code and exe. I run the exe on windowed mode and give no more than 1 fps I run the exe on fullscreen mode and run perflectly. i make my code very similar to nehe`s reflaction code. I work with allegrogl,c++,dev-cpp i run my code on fullscreen: void main() . . . allegro_gl_clear_settings(); allegro_gl_set (AGL_COLOR_DEPTH, 24); allegro_gl_set (AGL_Z_DEPTH, 8); allegro_gl_set(AGL_FULLSCREEN, TRUE); allegro_gl_set (AGL_DOUBLEBUFFER, 1); allegro_gl_set (AGL_SUGGEST, AGL_COLOR_DEPTH | AGL_Z_DEPTH | AGL_DOUBLEBUFFER ); set_gfx_mode(GFX_OPENGL, res_x,res_y , 0, 0); . . . } well i thing i did (maybe here i have the problem) I run on fullscreen mode 1024×768 and give no more than 1 fps I run on fullscreen mode 512×384 and give no more than 2 fps i think i dont know how to set fullscreen mode on allegrrogl, but the only thing i am very sure is if i run on windowed mode nehe´s reflaction exe it run relly relly slow, similar to my code. But if that run ok (nehe's reflaction exe) even on FULLSCREEN, am pretty sure i am doing something wrong. PLEASE HELP

Share this post


Link to post
Share on other sites
Palidine once again thank for the answer.

but,i think the subject is other.
Now i am asking about setting corectly the fullscreen mode on allegro.
I think like is a allegro question it must be on alternative library forum.
I post here after i post on opengl forum.
Why the user of allegro forum must have knowledge about openl forum?





Share this post


Link to post
Share on other sites
Quote:
Original post by xeexIII
I think like is a allegro question it must be on alternative library forum.

AllegroGL isn't Allegro; it's an OpenGL wrapper that lets you use it with Allegro. I'll leave this open in case an AllegroGL user can help you, but I have a feeling the other thread is more likely to get you an answer.

Share this post


Link to post
Share on other sites

This topic is 3863 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this